Add SSD to an existing umbrel configuration

Hi everyone, I have a Pine Quartz64 model A with Armbian (a version of Debian dedicated to this machine) I installed umbrel and everything seems to work. Now I need to install an SSD because the SDcard memory is not enough. I connected the ssd to the USB port, but I don’t know how to change the destination on Umbrel. Can someone help me? A thousand thanks.

Can anyone help me please?

Hi @doppiab!
Sorry for the delay, You can install Umbrel directly on your SSD using :
curl -L https://umbrel.sh | bash -s -- --install-path /some/path
make sure before that that Umbrel is not running from the SD card using:
sudo ~/umbrel/scripts/stop
Then you can shutdown Umbrel using the stopping script:
sudo /ssd_path/umbrel/scripts/stop
and move your files from your SD card to your SSD, then run Umbrel from your SSD again :
sudo /ssd_path/umbrel/scripts/start

When you confirm that everything worked and Umbrel is running using your SSD files, then you can erase the Umbrel files on the SD card.
Let us know if everything worked out correctly!

1 Like

Hi Marcaday, thanks for answering me!
I tried to install umbrell using this command on unformatted ssd:

curl -L https://umbrel.sh | bash -s – --install-path dev/sda/umbrel

but I get this error message:

Hit:1 http://deb.debian.org/debian sid InRelease
Get:3 https://cli.github.com/packages stable InRelease [3,917 B]
Ign:4 http://apt.armbian.com sid InRelease
Hit:2 https://box64.debian.ryanfortner.dev/debian ./ InRelease
Err:3 https://cli.github.com/packages stable InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 23F3D4EA75716059
Ign:4 http://apt.armbian.com sid InRelease
Ign:4 http://apt.armbian.com sid InRelease
Err:4 http://apt.armbian.com sid InRelease
502 Bad Gateway [IP: 130.185.239.78 80]
Reading package lists… Done
W: GPG error: https://cli.github.com/packages stable InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 23F3D4EA75716059
E: The repository ‘http://cli.github.com/packages stable InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Can you help me? Thank you.