Error: Failed to connect external drive

Hi,

I need help!

I purchased all the required/recommended hardware and was successful in flashing the zip file over to SD micro (had to format it).

At the final step, when everything is connected, umbrel.local says, Error: Failed to connect external drive

“There was an error connecting your external drive. Please consider using the recommended hardware listed on getumbrel.com.”

Even though I can see that the light on the hard drive is solid. I even tried to re-format the hard drive but it didn’t help either. Please advise!

(Note: I used Windows 10 to download and format SD micro and external hard drive. Also, connected ethernet cable with raspberry pi.)

Regards,

Sandy

It worked!

  1. rebuilt the sd micro flash by running “clean” (diskpart utility).

  2. ran “clean” on ssd (it kind of makes it factory default).

  3. also needed a new wire from usb 3 (A) to usb 3.1 © to connect raspberry pi (USB 3) to external hard drive (USB 3.1).

It is syncing now!

Thank you!

Hello,

I have a very similar issue, when I first tried to setup my node I couldn’t get Umbrel (v0.3.14) to connect with the SSD.

My setup:

  • Raspberry Pi 4 Model B 8GB + Raspberry Pi 4 USB-C official power supply
  • Crucial MX500 1TB SSD
  • Orico HDD enclosure 2,5" SATA3.0 to USB3.1 Type C (model 2588C3)
  • Samsung Pro Endurance Micro SDHC 32GB - MB-MJ32G

I tried everything described above but couldn’t get Umbrel to connect with the SSD. I read on some other thread that it might work with an older version of Umbrel. I redid the setup with Umbrel v0.3.8 and suddenly Umbrel connected to the SSD perfectly and my node started syncing!

I updated Umbrel during the syncing to v0.3.14 without problems.

After fully syncing the blockchain and testing everything, I tried restarting the node.
Unfortunately after restarting I’m running again into the same issue and Umbrel can’t connect to the SSD (same error message).

Any options? I really would like to avoid syncing the complete blockchain again and have the same problem again later on…

Kind regards,
Thor

Good afternoon.
I have exactly the same problem already bought another 1TB SSD disk at the moment it doesn’t work anyway. The error is as shown above: “Error: Failed to connect external drive”

There was an error connecting your external drive. Please consider using the recommended hardware listed on getumbrel.com.

I don’t know what to do anymore.
Can anyone help?

1 Like

Hi ppl.
@Thor e @sanjay I solved my problem by buying the “Orico HDD Enclosure” box because it gives transfers up to 10GB. Apparently the problem was with the plug that was connecting the Raspberry to the box. It was all 5 stars and the box is beautiful because it is transparent.
Thank you all.

Thanks for the info @Tsunamy.

Unfortunately I can’t order from Amazon in my country and have to buy the recommended enclosure in some other way. I couldn’t find the transparent enclosure in an alternative shop, however I did find a black one with exactly the same specs (as far as I can see?):

As you can see, it can also transfer up to 10Gbps so this shouldn’t be the issue.

Was it the cable itself that was the issue?

Kind regards,
Thor

Good night @thor. Yes, this same record must give the difference must be in the “aesthetics”. It worked perfectly with me and there are two cables inside. USB - USB´C and USB´C - USB´C .

My disk

all this. Hope this helps.

Thanks.

Specs are identical to mine, so it would be unlikely that this is my issue.
Any devs out here that can help to troubleshoot?

I really don’t know how to continue…

I had same issue. It ended up being due to the fact that I wasn’t using a USB 3 cable to connect SSD to pi. Got a new USB 3.1 to USB C cable and now I could setup

I have the same issue. I’ve bought 100% of the recommended hardware off umbrel. Even ordered a replacement Crucial SSD incase the first SSD I received was corrupt, same issue.

It stays on “Starting Umbrel…” for a long time:

Then shows me the same “Error: Failed to connect external drive” error.

I’ve ssh'd into umbrel with ssh umbrel@umbrel.local then ran ~/umbrel/scripts/debug --upload and all I get is the following:

umbrel@umbrel:~ $ ~/umbrel/scripts/debug --upload
[REDACTED_LOTS_OF_DEBUG_LINES...]
================
==== Result ====
================
This script could not automatically detect an issue with your Umbrel.
Please share the following links and paste it in the Umbrel Telegram group (https://t.me/getumbrel) so we can help you with your problem.
tail: cannot open '/home/umbrel/umbrel/scripts/../logs/memory-monitor.log' for reading: No such file or directory
tail: cannot open 'logs/karen.log' for reading: No such file or directory
https://umbrel-paste.vercel.app/
https://umbrel-paste.vercel.app/
https://umbrel-paste.vercel.app/

Note the This script could not automatically detect an issue with your Umbrel. line in the result of the script.

So, as it stands:

  • Using 100% of recommended hardware (Same ORICO connector one someone mentioned in this thread).
  • Using latest umbrel release.
  • Tried in both USB 3.0 and USB 2.0 ports on the RP4.
  • Tried multiple different recommended SSD’s.
  • No errors detected from script.

There’s nothing else I can think of. I’ve spent hours debugging this trying different ways and I’m pretty convinced it’s a bug with umbrel.

If anyone else has any ideas/solutions that worked for them please let me know.

Also forgot to mentioned ^ I’ve also re-flashed the SD card on every occasion after turning off/restarting umbrel or the RP4. Same error…

Update on my issue: It seems that the cable delivered with my Orico SSD enclosure was not a USB3 (type C to type A) cable even though the cover seems to state it is. You can actually check it quite easily by making sure the USB type C to A has a blue color inside the male type A socket. Just like the blue color on your Pi USB 3 sockets.

I bought a new cable and now the Umbrel seems to work fine…