Error: Failed to start containers

Hello

I am getting the following error: Error: Failed to start containers
Tried reflashing the OS, but no succes.
also tried
sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service

and
sudo systemctl stop docker.service && sudo systemctl stop docker.socket && sudo rm -rf /var/lib/docker/* && sudo umount /var/lib/docker || true && sudo rm -rf /mnt/data/docker/* && sudo reboot

no luck

any suggestions?

Many thanks!

after that command, did you update again umbrelOS to latest version?
Try reflashing the mSD card now after you did that.
Those startup strings doesn’t sound good.
variable is not set. Defaulting to a blank string.

Did the OS flash first. then the commands. Will do a reflash. Keep you posted. Thanks for the fast reply

Dear DarthCoin

Bought a new SD card because I was having some trouble reflashing the OS on the SD card.
Flashed the OS on the new SD card, no issues there with the new card.
But I am still getting the same errors when trying to start umbrel
Any further suggestions or does this not look good…

ocap.

I find myself in the same situation. I`ve rebooted the system, have already also tried " sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service" and reflashed the SD card.

Still stuck in the /start page, loading…

If you already reset those services and reflashed the mSD, sincerely, I don’t have other idea what could be. I’ve looked into the logs and seems that is the same error with not starting the docker containers.
Maybe is something corrupted on your SSD.
If you do not have funds in that node wallet (onchain and/or LN) I sugest to start over from scratch with erasing the SSD disk also, maybe the drive have some bad sectors.

@louneskmt do you have any other idea?

I managed to restart my node completely following these steps:

You have error that a specific Umbrel App do not start or it keeps staying in “installing”, maybe the docker container for that app it wasn’t installed correctly or it hangs.

Step 1 - Enter using SSH into your Umbrel node:

Step 2 - stop Umbrel node with:

cd umbrel

sudo ./scripts/stop

Step 3 - clean / reconfigure the broken container:

sudo rm -f .env && sudo ./scripts/configure

Step 4 - Restart your node:

sudo ./scripts/start

Gad you could sort it out by yourself. And you @ocap?

Also, on UmbrelOS, you should use sudo systemctl <start | stop> umbrel-startup instead of those scripts.

Hi @louneskmt

No I haven’t had any luck.
I run into error while stopping service --> Couldn’t find env file: /home/umbrel/umbrel/.env
as well as sudo rm .env --> cannot remove ‘.env’: No such file or directory

pastebin with sudo ./scripts/stop

pastebin with logs is in the above messages

any help is greatly appreciated.

ocap

Please try again, I’ve updated @21isenough message to fix this.

Hello @louneskmt

These modified pieces of code work like magic :wink:
Node is back up and running. Bitcoin core is already 100% synced. BTC wallet and lightning wallet are still not showing the transactions and balance. But i guess this can take a while?

Many thanks! Is there a place where I can send the umbrel team some sats? (once my lightning wallet comes back online)

ocap

1 Like

If nothing appears within the next 24 hours, please send me a DM.

No worries! We do not accept donations, but we really appreciate your continuous support :grin:

1 Like