How to activate Wifi?

Hello,
My Raspi 4 is connected via Ethernet but most of my devices are connected via Wifi to my network.
How can I configure and activate wifi access for my Umbrel?
Many thanks!

this should help you:

2 Likes
  • Create a file wpa_supplicant.conf in the boot partition of the microSD card with the following content. Note that the network name (ssid) and password need to be in double-quotes (like psk="password")

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

update_config=1

country=[COUNTRY_CODE]

network={

 ssid="[WIFI_SSID]"

 psk="[WIFI_PASSWORD]"

}

  • Replace [COUNTRY_CODE] with the ISO2 code of your country (eg. US)

  • Replace [WIFI_SSID] and [WIFI_PASSWORD] with the credentials for your own WiFi.

1 Like

Strangly enough, this doesn’t work and when i check the boot partition again, that file has been deleted.

Will try this one too. Didn’t expect the Wifi connection to be so difficult.

Update: I can ping the device (macbook pro via wifi) but I can’t browse. I can browse to it via the IP-address and see to login screen but after typing in my password it won’t go to the dashboard. It’s like the screen freezes.
Same on a new Macbook Air. Tried on Firefox and Brave.

Access via Tor also works fine and on a Windows machine it works fine also (via wifi). IOS works too.
Guess it’s the Mac OS then?

ist not difficult at all, just shutdown your umbrel, take out SD Card and plug it into your reader
then follow step 4 . put your SD card back and restart your Pi ( without the ethernet connection !)
worked for me.

1 Like

That’s because your local PC from where you access “forget” in local DNS information about that IP.
You will need to add in your local hosts file the information
umbrel.local
or just access it using the IP, is just fine

1 Like

That works indeed, thanks

Thank you. It worked for me.
My thanks and appreciation.

I’m having issues with this as well. when I tried going to umbre.local it wouldn’t pop anything up on my Mac. I have been trying to download one of the wifi files and none of them are downloading.

read these 2 guides:
how to set a static IP for your node
and
troubleshooting manual

Thanks for this, It worked for me.
How do I remove it to go back to Ethernet cable? Plugging the SD back into the desktop I can no longer see the wpa_supplicant.conf file to delete it.