How to create a Lightning Node Alias?

cd to your umbrel directory first!

cd ~/umbrel
docker-compose restart lnd

1 Like

ok thanks, now it’s restarting

i think this didn’t worked, restarted it 2 times, any ideas?

Restore your backup of lnd.conf and restart LND again, to see if it works without your changes!

now it worked, thanks for your help! :orange_heart::pray:

So I was able to set the alias following the above instrcutions. But how do you set an alias that includes a blank space or a symbol? Could someone please share an instruction on how to set the following example?

Ride the Lightning :zap:

Hi, I made the changes and everything seemed to go well, but now I’m getting an error on RTL after restarting. I’ve added alias on first line (it includes lowercase and uppercase and an underscore instead of space) and changed color.

Any idea on how to fix this?

how to restore lnd.conf ?
Thanks

Restore to what?

If you made a backup of your original file e.g. lnd.conf.bak just rename it using:

cp lnd.conf.bak lnd.conf

… and restart lnd again :slight_smile:

You can place emojis in your node alias to spice things up a bit! Don’t go too crazy please, and include some regular characters so people can easily search for your node. To add an emoji simply copy the emoji (from an internet webpage, for example) and paste it into the LND conf file where you would normally edit your alias. It may not show up properly in command line, but when you save and exit it should show up properly nearly everywhere else!

I walked back all the steps, but RPC is not working now.
I don’t have a back up but I was wondering if I can just find a copy of the original formatting within the conf file, and proceed to correct it manually.

I finally managed to change color and alias, but then moved on to install a watchtower, and screwed it up again. Tried removing those lines, saving and restarting but now I can’t get rid of RPC error.

Thanks for helping!

Check your lnd.conf carefully as even a withespace on the wrong place can mess it up!

1 Like

Great guide thanks alot :smiley:

1 Like

Thanks for this easy guide. I had fun!

Awesome. Easy to follow instructions that make this really easy to understand and complete. Thanks!

Nice, that worked out. I can se my ALIAS i RTL but I can not see it showing in https://explorer.acinq.co/
Do you know why?

Thanx for posting this, Deeke. I had to review how to use the editor, but it worked just like you said. Good job.

This video helped make this a lot easier for those of you like me who need to visually follow these things step-by-step

1 Like

Ha, first time I did this it didn’t work, total newb, because I used ‘i’ instead of ‘l’ for lnd.conf (i thought it was a capital I, but it is lower l for lightning network daemon).

I would also like to know the answer to this question :smiley: