I cannot connect locally to my Zap wallet

I am pasting my lndconnect gRPC (Local) connection string on mobile (android) or PC (Windows) and it doesn’t work…

zap error

What can i do?

Desktop Zap do not support Tor connection so use umbrel.local/IP instead of onion address
Zap Android, use it with Orbot Tor, adding it in the VPN apps list. Start first orbot, wait to be connected to Tor network, and only after that start Zap and connect it using onion address

Yeah, as i said, i used local ip string and it still doesn’t work… Maybe i should open some ports on router or something, i don’t know…

no, no need to open any ports on LAN.
In your ZAp desktop you should have in connection string something like this:
lndconnect://node.local:10009?cert=…

You should consider adding into your pc hosts file the Ip of your node
192… node.local

Sorry, i just simple normie trying to figure all this out. Can you elaborate what is adding into my pc hosts file the ip of my node? How to do that? Sorry for noob questions.

No problem man, nobody is born with all the knowledge :smile:
First you need to know your node local IP. You can find out in your router settings or running arp -a from a command line prompt, from a computer in the same LAN with your node.
It will show you a list of computers and IPs in your LAN. One is your node.

If you use Windows, follow this guide
If you use Mac, follow this guide

you should add a line to contain IP and the name of the host (computer), in this case umbrel.local
It will be like
192.168.1.x umbrel.local (where 192.168.1.x is the IP of your node)
That’s all

1 Like

Wow yeah, it worked! Thank you! But i have the same problem with my Android, can’t access Umbrel with Zap on local network. I guess it is the same, to change hosts on Android as well? Maybe there is an easier way?

For Android use Orbot app activating Tor VPN for the app zap. Then connect Zap with onion address

Yeah i tried that already, everything as instructed, but it doesn’t connect… Anyway thank you for support!