Introducing the plug-and-play Umbrel server from The Bitcoin Machines

I’m beginning to think there is something wrong with SSD.

I think you should have just asking people to subscribe for your service rather than messing with their DIY nodes that run your umbrel…i think im going to wipe my rasbpi4 i set up and try another OS. May be going back to bitccore that didn’t promise much but yet gives peace of mind.

Super excited to get started!

Where can I find the directions to set up my new TBM? I used the ethernet cable to connect the TBM and my router, plugged in the TBM power cable. I can see the TBM screen is displaying various info (price, time, etc…) but I cannot seem to load the http://umbrel.local. Am I missing a step? Do I need to hardline my comp to connect with TBM?

I have the same exact problem than this person. No instructions whatsoever were provided with the Bitcoin Machine telling to plug the usb wire. Now that everything is properly connected I am stuck on the start screen Umbrel logo with loading button. Many will be having the same problem.

Here’s how I think the issue can probably be easily reproduced:

  1. Turn the Bitcoin Machine on without the usb cable, let it run for a couple of minutes
  2. Try to connect to Umbrel through lan.
  3. Turn the Bitcoin Machine off.
  4. Plug the usb wire between the ssd and the raspberry pi
  5. Turn the Bitcoin Machine on, try to connect through lan.

Now, let’s find a fix!

Have you plugged the usb cable? I wasn’t aware that you have to do that also. Here for me also umbrel.local isn’t working, I need write the lan address 192.168.0.*** , then I can connect but I get stuck on the home screen with the loading button. By ssh connection, I see the sync progress in the debug log. I will probably have to deassemble everything to re-flash the sd card if there’s no solutions, but Im affraid to loose what I already synced.

I just found how to solve my problem! Through the guide here : Umbrel Troubleshooting Guide
And in the section: Login screen it just freeze, can’t login
And I haven’t lost any sync progress, now I’m in the dashboard!!

Thank you for the response!

I do have the usb cables plugged in (forgot to mention that).

I have been staring at this “Starting Umbrel…” screen for a while, unfortunately I can’t quite make it to the login screen.

Here, while I was searching to solve my issue, I also updated the raspberry firmware and umbrel software to their latest updates and rebooted the node (through ssh all the time). In debug logs, do you see the height of the blocks progressing, like synchronisation happening? Here, the syncing was progressing but the debug logs was telling me that karen, tor and lightning had errors and weren’t running. For me I suspect it was maybe some userdata (like keys, empty entries, or something) that had problem stored on the ssd, and that needed to be wiped and resetted. I hope you get through this issue, it’s super annoying to begin with that, but as I’ve read in the troobleshooting guides, it’s true that patience is key. good luck!

Got it!! Prabhu Devaraju with tech support got me online!! Everything is great!!

Hey - do you know if a DIY screen is possible if you’re running a DIY Pi?

i have this device arriving tomorrow. i would prefer to flash the device and install from a fresh download. trust but verify type of deal. any advice on where to start the process?

any help appreciated.

Newbie kinda frustrated here…

Also having no other instruction then to plug in the router, I did not plug the SSD blue cable at first startup.

Reading here I realized i had to. Now I’m not stuck also but NOT at loading but the message after.

The page in umbrel.local after the loading page says :

" Error: No external drive found

Please connect an external drive (at least 1TB) to a USB 3.0 port (blue color) on your Raspberry Pi and restart your Umbrel. […]"

I tried the shutting down and the restarting options but still same message coming up.

I tried contacting TBM from their email support at support@doido.in … still haven’t heard back.

I’m trying my luck in this Community. Anyone else having this issue?

I had the same issue. Forgot to plug in the ssd on first startup. Turned off, plugged in drive and restarted. The issue went away.

Second larger issue were ssd disconnects every 20 minutes. “dmesg” was showing many i/o errors.

I contacted support via twitter, they got back within 24 hours and were very patient and helpful. They suggested replacing USB cable.

I got a 0.5m high quality usb3 cable and all issues were resolved.

Umbrel is rock solid, syncing is faster and I have no i/o errors.

Keep contacting TBM and they will troubleshoot with you.

Edit: I ran fsck after replacing the cable. It was a pain to run due to disk (/dev/sda1) being active but one workaround was to unplug it and plug it back in. It then got a new device (/dev/sdb1) and was not used. Not very nice for the system to unplug but I needed to fix the filesystem!

It was the USB cable for me.

With supplied cable I was getting many i/o errors and also “badblocks” was showing many bad blocks on ssd.

After replacing the cable it all went away.

Same here. New cable, all good.

just got mine today, happy to see you guys haven’t improve the instructions a month and half later

LCD Details here… https://thebitcoinmachines.com/lcd/

I am newbie. Is this receiving inbound connections? I want to run Bitcoin node to support the network.

Not by default since it is in privacy mode and using tor hidden services.

It’s trivial to open it to incoming connections but it has privacy considerations.