Lightning Node not starting

I need help. I lightning node has not been working right a few weeks then I first noticed all the channels drop off so I restarted. Then it had to sync bitcoin node. That was done but Lightning Node doesn’t spin up. I updated the firmware and restarted. Ride the Lighting seems to work and the Bitcoin Node but the Lightning Node is stuck on about 60%, Thnederhub couldn’t log in and LNDg shows an error. I tried force shutting down the Lightning Node via SSH but it says- Error: App “Lightning-node” is not installed yet
I am freaking out sats are lost as I am sure there were 50,000,000 and now RTL says 32. I am too much of a noob for this node business…

1 Like

Here is the log for lightning
lightning

Attaching to lightning_app_1, lightning_tor_server_1, lightning_lnd_1, lightning_tor_1, lightning_app_proxy_1
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
app_proxy_1 | Validating token: 52a91c686319 …
lnd_1 | 2022-11-21 07:20:35.947 [INF] CHDB: Pruned unconnected node 024a370500c2fa44f405ccf3246e6f42541b194c290d364c85f8b6a9a786107ca8 from channel graph
lnd_1 | 2022-11-21 07:20:35.948 [INF] CHDB: Pruned unconnected node 032475c0b56687c589c3409d0aa216178ec923a992e1e835dc01456cf88983ee75 from channel graph
lnd_1 | 2022-11-21 07:20:35.948 [INF] CHDB: Pruned 2 unconnected nodes from the channel graph
lnd_1 | 2022-11-21 07:20:37.408 [INF] CRTR: Block 00000000000000000004d3c557b7ae7def1913efd90c14f74728eac2696f12bb (height=764109) closed 2 channels
lnd_1 | 2022-11-21 07:20:41.296 [INF] DISC: Broadcasting 17 new announcements in 2 sub batches
lnd_1 | 2022-11-21 07:20:54.078 [INF] CRTR: Processed channels=0 updates=9 nodes=0 in last 1m0.000053583s
lnd_1 | 2022-11-21 07:20:56.061 [INF] NTFN: New block: height=764109, sha=00000000000000000004d3c557b7ae7def1913efd90c14f74728eac2696f12bb
lnd_1 | 2022-11-21 07:20:56.061 [INF] UTXN: Attempting to graduate height=764109: num_kids=0, num_babies=0
lnd_1 | 2022-11-21 07:21:54.078 [INF] CRTR: Processed channels=0 updates=9 nodes=0 in last 1m0.000364607s
lnd_1 | 2022-11-21 07:22:11.295 [INF] DISC: Broadcasting 11 new announcements in 2 sub batches
tor_1 | Nov 21 00:14:14.000 [notice] No circuits are opened. Relaxed timeout for circuit 29926 (a Hidden service: Establishing introduction point 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [23 similar message(s) suppressed in last 8100 seconds]
tor_1 | Nov 21 01:49:13.000 [notice] No circuits are opened. Relaxed timeout for circuit 30092 (a Measuring circuit timeout 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [22 similar message(s) suppressed in last 5700 seconds]
tor_1 | Nov 21 02:09:04.000 [notice] Heartbeat: Tor’s uptime is 1 day 6:00 hours, with 15 circuits open. I’ve sent 22.21 MB and received 20.42 MB. I’ve received 0 connections on IPv4 and 0 on IPv6. I’ve made 24724 connections with IPv4 and 0 with IPv6.
tor_1 | Nov 21 02:09:04.000 [notice] While bootstrapping, fetched this many bytes: 569885 (consensus network-status fetch); 26689 (authority cert fetch); 4485932 (microdescriptor fetch)
tor_1 | Nov 21 02:09:04.000 [notice] While not bootstrapping, fetched this many bytes: 902369 (consensus network-status fetch); 359748 (microdescriptor fetch)
tor_1 | Nov 21 02:49:17.000 [notice] No circuits are opened. Relaxed timeout for circuit 30284 (a Hidden service: Establishing introduction point 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [31 similar message(s) suppressed in last 3660 seconds]
tor_1 | Nov 21 04:06:14.000 [notice] No circuits are opened. Relaxed timeout for circuit 30326 (a Measuring circuit timeout 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [23 similar message(s) suppressed in last 4620 seconds]
tor_1 | Nov 21 06:04:15.000 [notice] No circuits are opened. Relaxed timeout for circuit 30677 (a Hidden service: Establishing introduction point 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [18 similar message(s) suppressed in last 7080 seconds]
tor_1 | Nov 21 07:20:24.000 [notice] No circuits are opened. Relaxed timeout for circuit 30763 (a Measuring circuit timeout 4-hop circuit in state doing handshakes with channel state open) to 60000ms. However, it appears the circuit has timed out anyway. [17 similar message(s) suppressed in last 4620 seconds]
app_1 |
app_1 | umbrel-middleware
app_1 | Checking LND status…
app_1 | E1121 07:22:40.304413248 31 ssl_transport_security.cc:1245] Handshake failed with fatal error SSL_ERROR_SSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed.
app_1 | Waiting for LND…
app_1 | E1121 07:22:41.001510275 31 ssl_transport_security.cc:1245] Handshake failed with fatal error SSL_ERROR_SSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed.
app_1 | ::ffff:10.21.0.13 - - [Mon, 21 Nov 2022 07:22:41 GMT] “GET /v1/lnd/info/status HTTP/1.1” 304 - “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.5249.168 Safari/537.36”
app_1 |
app_1 | umbrel-middleware
app_1 | E1121 07:22:41.042732230 31 ssl_transport_security.cc:1245] Handshake failed with fatal error SSL_ERROR_SSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed.

Kind of discouraging to not see other umbrel members jumping in to help. I’m pretty technical, but just getting into LND, are you a member of the plebnet group on Telegram? there’s a LOT more help there than what I see on this forum…

Hey thanks for the response! I ended up rebooting LND. I found some code that did the trick for SSH using Putty. Code is /home/umbrel/umbrel/scripts/app compose lightning restart lnd
However, jumped on the node again today to see Lightning Node (lnd) stuck again and therefore other services like RTL had errors. I used the same code to reboot again and seems fine now. Not sure why lnd is just randomly getting stuck/stopping?.

Not sure about plebnet but did try the telegram Umbrel channel - https://t.me/getumbrel but ended up solving it as per above.
Is plebnet this one? https://t.me/plebnet