Low Ram Error Message

Getting this low ram message on Umbrel. I’m uninstalling some apps but am wondering how to upgrade a pi without killing my node? Is this possible? @DarthCoin

I’ve also started getting this error after the most recent update.

I am also getting this error. I think I should have gotten the 8GB version. What else can we do besides deleting apps?

I recently started getting this message. When I look at the logs mempool space is taking up a lot of ram, more than it had previously. I only have 3 apps running and didn’t get this message before the recent update.

Hey guys! Could you share the RAM usage (in percent) of each app (you can get that in the logs: Settings > Troubleshoot) and your Pi version?

I updated Umbrel yesterday and that seemed to bring ram usage down a little bit. It’s still in the 2.8G range with only 3 apps installed.


And I have the Raspberry Pi 4 Model B 2019 Quad Core 64 Bit WiFi Bluetooth (4GB)

Brel log

I reinstalled mempool space and did not have the ram warning when logging off/on. It is using less memory then before I uninstalled.

@erinemalone @WalletInspector Thanks for the details. It seems that the Mempool app is using a lot memory. There is a discussion ongoing with Mempool devs to solve this: https://github.com/mempool/mempool/issues/486.

is there a command to stop the mempool app? Is it critical for operations?

I have same memory problem. I bought the recommended 4 GB pi and don’t run any applications. It worked great for a few months and then this started happening.

I am debating upgrading to 3.14, but I am remote from my node, so it is risky that i run into problems and need to physically be at my device.

It has also crashed one i think due to this problem. Is there any way to see past logs (the log download is only the most recent one).

Thanks all for any help!

Unfortunately, there is no way to stop an app without installing it.

Can you also check the memory usage in the logs?