New Umbrel 4.0 - Nextcloud App

Greetings
New Umbrel 4.0 - Nextcloud App
I need to access a file with a different device and I get the following error…

"Access through untrusted domain
Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php. "

How can I change the config.php file ?
Thanks

I’ve figured out how to get there.
I can now access files shared to the outside.
I will post tomorrow the solution.

I have created account in Tor browser and can access from outside. Android app works with Orbot. It’s slow for handling big files. Not ideal, waiting for solution how edit trusted domains.

The solution was as follows:
Nextcloud installed on the Raspbery Pi.
I used a Windows computer with SSH installed to access the RPi.
I used “find / -name config.php” and the following path resulted:
“/umbrel/app-data/nextcoud/data/nextcoud/config/config.php”
I edited with “nano” and added trusted domains and it worked perfectly.

1 Like

Working! Thanks!

When you say you “Added trusted domains and it worked perfectly.” what did you add?

I’m looking at config.sample.php, list of IP addresses or domains but unclear what this means for editng config.php. Do I add the Tor onion address generated by Umbrel? *.onion?

OK, here’s what worked for me. I’m a noob so if someone else reponds and says this is disastrous, please follow them. Also, this functionality should be default so no more noobs like me need to edit.

  1. Login to RPi as umbrel
  2. In terminal enter:
    sudo nano umbrel/app-data/nextcloud/data/nextcloud/config/config.php
  3. In the section of the file that mentions ‘trusted_domains’, add an element to the array that allows ‘*.onion’ (any onion domain (may be a massive security hole or something, but I wanted to accommodate if my onion url changes)

Add this line:
1 => ‘*.onion’

Your file should look like this:

'trusted_domains' => 
array (
0 => 'umbrel.local:8081',
1 => '*.onion'
),
  1. Save the file (control O, then hit return)

Now that I’ve got NextCloud accessible over Tor, I want to connect it to one of the NextCloud apps on iOS. But it looks like they don’t support Tor.

What are you all doing with NextCloud once you get access over Tor? Are you just accessing it in Tor browser or something?

I don’t know about on IOS, but on Android you have to run an app to enable the TOR network (Orbot) and add Nextcloud to the list of Tor enabled apps

Ah okay. It looks like iOS has no way to enable Tor systemwide – only download and run one-off apps like “Tor Browser” etc. Looks like iOS + NextCloud over Tor is DOA.

Worked, but if you want to do it safer: use the exact .onion url that connects to nextcloud via tor in the config file. That way ONLY that url can get in. (simply connect to nextcloud via tor to find that url :wink: Copy, paste, writeout, Done.

1 Like

I can´t connect to nextcloud from local network devices.
“Access through untrusted domain”

What do I have to enter so that I can access it from the local network?
Here my config:

‘trusted_domains’ => array ( 0 => ‘localhost’, 1 => ‘umbrel.local:8081’, 2 => ‘xxxxxxxxxxxxxxxxxx.onion’),

Greetings to the Community

I got it:
add the local IP address of the raspberry pie and it works:

‘trusted_domains’ => array ( 0 => ‘192.1xx.1xx.xx’, 1 => ‘umbrel.local:8081’, 2 => ‘xxxxxxxxxxxxxxxxxx.onion’),

found another solution :

Add node IP into your hosts file

  • Go to the hosts file located into: C\Windows\system32\drivers\etc\ If you can’t see it, go to view folder options and select “show hidden files and folders”.
  • copy it onto your desktop and start editing with notepad
  • add the following line:

192.168.x.x umbrel.local

(replace 192.168.x.x with your local IP assigned for your node)