Not able to connect Electrum desktop wallet to Umbrel over tor

Hello together,
since days I try to connect the Electrum desktop wallet (macos) via tor with the umbrel node (according the umbrel-tutorial in the section “Connect wallet”). Tor is running successfully as a background service and is listening on port localhost:9050.

Umbrel runs on a raspPi4 with SSD over wifi. The BTC-Chain is synced since around 2 weeks.

Would be great if any being here would have the patience to help me to bring up this node successfully… Thank you!

1 Like

Tor is a bit silly lately.
There’s a patch 4.7.7 but you will need to update your UmbrelOS. Better wait for umbrel guys to update it, if you do not know how to do it.

Another trick is to use local IP of your node to connect to your electrum server.
But for that also you need to open the port 50001 in umbrel ufw.
And that’s it, you can connect on local IP:50001 with your electrum app. No more Tor.

Another trick is to use Tailscale, in special when you are out of your LAN. Works nice. Private VPN.

Thanks brother….do you have a tut for how to open this port 50001 at umbrel handy?

SSH
sudo ufw allow
sudo ufw allow 50001

Thanks again… I very much appreciate your patience!

But anyhow “ufw” command won’t work at my installation….any further ideas?

sudo apt-get install ufw -y

Ok sorry….this came from lacy mind.
I had to install it first “sudo apt install ufw”

So I changed the rules as you suggested and edited the “network —> server” entry in electrum with 192.168.0.110:50001” and let the “proxy” checkboxes unchecked….

….but still electrum still doesn’t connect

hmmm, seems you have other problems there.
did you checked the logs of electrs?
SSH
cd umbrel
docker-compose logs electrs

See if is the index completed.

One important thing: must be in this format: 192.168.x.x:50001:t (or whatever local IP you have), but must contain that 50001:t

1 Like

Brother thank you very much! The “:t” made it finally.

That means in “Network”-window —> “Server” I put “192.168.0.110:50001:t” and
the “Proxy”-Checkboxes I left unchecked!

I super appreciate your support and will keep this as motivation to pass on knowledge when I get the opportunity… Thank you very much!

2 Likes