Problem with 0.4.4 upgrade

Hm, same problem still - makes me think if I destroyed something on the external HD?

You are in ‘detached HEAD’ state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

git checkout -b

=============== UPDATE ================
========== Stage: Download ============

An update is already in progress. Exiting now.

Making progress here and leaving this here in case people have similar problem.

I managed to stop this stuck update with
sudo rm statuses/update-in-progress

then I reran the update to v.0.4.1 and that seems to have worked this time.
Latest problem is though that I now get a constant Spinning Wheel on Starting Umbrel… screen when trying to connect via browser

so if I run ./scripts/start

I get

ERROR: readlink /var/lib/docker/overlay2: invalid argument

Anyone know what to do about that?

Looks like I am finally back up and running - I ended up doing a multitude of things I dont know what they are doing but I’m back up and running v0.4.4 now and lets hope it stays alive

1 Like

Hi, I have the same problem. After upgrading to v0.4.4 umbrel constantly syncing to 100% then start again from about 99.95% and so on…

Umbrel logs:

electrs logs:

Thank you for any help

You can run the debug command and upload it to a webhost automatically to share it here as a link:
$ umbrel/scripts/debug --upload

Without the logs it’ll be tricky. Use pastebin or other services so we can have a look

Thank you for reply. I’ve updated my previous post with logs

Really tricky. I’m not 100% sure, but here a few hints I found checking your logs

  1. In Umbrel logs, it states Umbrel version


Flashed OS version

try updating Umbrel by flashing your SD card with the newest version. It should find your old setup on the SSD and might mitigate the rest of the issues. because

  1. Bitcoin logfile and especially the electr logs shows going back since it can’t validate one or two of the last blocks of the chain. Usually it should trigger a reindex, but apparently it doesn’t. Hence LND, electr and all other daemons cannot start

So once you’ve done 1), and it doesn’t solve it, I would try to add reindex-chainstate=1 to your bitcoin.conf. Here is the exact guide how to do so:

Thank you for checking my logs and for the detailed explanation of possible problem solving. I’ll try to do what you recommend and reply with results.

I flashed Umbrel v0.4.4 to microSD and started Raspberry Pi4 with this new version of Umbrel.

This time according to logs it looks like the problem is with locked wallet:

Attaching to lnd
lnd | 2021-10-19 17:54:56.733 [ERR] RPCS: [/lnrpc.Lightning/ListPayments]: wallet locked, unlock it to enable full RPC access

Umbrel log:

Will be grateful for help)

We’ll get there, step by step.
@DarthCoin did a fantastic job with the troubleshooting guide linked below. Try the following. Uncertain if your wallet password is actually moneyprintergobrrr like he suggested, or your password you use to login to the UI. You can’t break anything here, so have a try

Wallet is locked. How to unlock it in command line

ssh -t umbrel@umbrel.local 

The prompted password is your dashboard password.
Then execute:

cd ~/umbrel && docker-compose exec lnd /bin/bash


lncli unlock

When prompted, enter the password moneyprintergobrrr
Done. Now open Umbrel dashboard page and login.

Source: Umbrel Troubleshooting Guide

Performed all actions as prescribed by @DarthCoin guide:

umbrel@umbrel:~ $ cd ~/umbrel && docker-compose exec lnd /bin/bash
bash-5.1$ lncli unlock
Input wallet password:
lnd successfully unlocked!

But Umbrel log in the user interface still shows that wallet locked, unlock it to enable full RPC access

Could be that you need to restart LND, but first check the logs

  • Umbrel Debug log: Does the LND section look different, do you see a locked wallet issue there somewhere
  • If to short there, you can look at LND logs via
tail -f ~/umbrel/lnd/logs/bitcoin/mainnet/lnd.log
  • If it looks like LND is catching up with the Blockchain, let’s wait. If not
cd umbrel && docker-compose restart lnd

And best watch LND log at the same time in a second terminal

I have a similar issue. Here are my lnd logs. This is after doing lncli unlock
2021-10-19 20:03:48.016 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:03:52.586 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:03:53.020 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:03:58.024 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:03:59.426 [INF] LTND: Received terminated

2021-10-19 20:03:59.426 [INF] LTND: Shutting down…

2021-10-19 20:03:59.426 [INF] LTND: Gracefully shutting down.

2021-10-19 20:03:59.426 [ERR] LTND: unable to set up wallet password listeners: shutting down

2021-10-19 20:03:59.482 [INF] LTND: Shutdown complete2021-10-19 20:04:01.437 [INF] LTND: Version: 0.13.3-beta commit=v0.13.3-beta, build=production, logging=default, debuglevel=info

2021-10-19 20:04:01.438 [INF] LTND: Active chain: Bitcoin (network=mainnet)

2021-10-19 20:04:01.478 [INF] RPCS: RPC server listening on

2021-10-19 20:04:01.485 [INF] RPCS: gRPC proxy started at

2021-10-19 20:04:01.485 [INF] LTND: Opening the main database, this might take a few minutes…

2021-10-19 20:04:01.486 [INF] LTND: Opening bbolt database, sync_freelist=false, auto_compact=false

2021-10-19 20:04:02.789 [INF] CHDB: Checking for schema update: latest_version=22, db_version=22

2021-10-19 20:04:02.789 [INF] LTND: Database now open (time_to_open=1.303603434s)!

2021-10-19 20:04:02.790 [INF] LTND: Waiting for wallet encryption password. Use lncli create to create a wallet, lncli unlock to unlock an existing wallet, or lncli changepassword to change the password of an existing wallet and unlock it.

2021-10-19 20:04:03.031 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:04:05.710 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

2021-10-19 20:04:08.034 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet locked, unlock it to enable full RPC access

Not sure if you’re up to the gamble, but it could be something wrong in your LND.conf? Like anchor-channels active or something like this?

Last resort: Make a copy of your lnd.conf, delete the main one and restart the node.
run (but be sure what you do)

cp  ~/umbrel/lnd.conf  ~/umbrel/lnd.bak && rm ~/umbrel/lnd/lnd.conf && ~/umbrel/scripts/configure && sudo reboot

I have been following this thread and tired a few things.
Problems started when I upgraded to 0.4.4 from 0.4.3.

I’m back at Umbrel 0.4.1
and my latest log file is

Any help would be greatly appreciated.

Guys, I also moved back to v0.4.1 using this command:

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.1

wallet unlocked automaticaly and everything is working

1 Like

With v0.4.6 the same problem

Just a quick follow-up.

i tried to downgrade to 0.4.3 but that did not help.

I decided to start off with a fresh install of Ubuntu 20.04 and the 0.4.5 installation package. Used my seed and can see my BTC on-chain funds immediately. I then stopped Umbrel (via ssh) and copied my lnd wallet files (details in the amazing troubleshooting guide). Restarted Umbrel (using the start script) and I can now see my lnd balance. Channels also came back but I already had 2 forced close.

Just left it running (since Friday night) and now bitcoin is finally synced to 100%. I’m now waiting for Electrs re-index to complete (I think it will be another few hours).

All in all - a good learning experience (got a chance to learn all the docker / docker-compose commands). I think the main lesson-learn for me is really to be patient and try to learn all the details of how each part of the system works.

Good Luck on the recovery to all.

Oh. One more thing – I’m going to hold off the 0.4.6 upgrade…

1 Like

Have issues with upgrading.
It takes more than 1h and still wasn’t done and I did what was written to: NOT TO DO: restart a page.

So I get error.
Unplugged Pi from power and plugged on.
Now when I connect my umberl node - it says: “Starting Umber” - and it’s also going very long.

Please, can someone tell me - then eventually it will start up or I need to clean my Pi card and SSD and recover my account with seed?

@xstaffquick Just reflash your Micro SD card with the latest version of Umbrel, and you should be fine. Don’t clear/wipe your SSD, as there’s nothing wrong with it.

@DHD Thx. re-booted with v0.4.6 version.
Nothing change.
I getting the same screen with two options: restart or shutdown. [after restart it will try to start but throw me to the same window with restart/shutdown options]
How can I fix it?