Ride the lightning stuck in starting.........loop

after update, and reboot. ride the lightning is just stuck in “starting…” mode and still stuck for 12 hours. just flashes in the app menu, and hoovering over it just has the infinite circle.

3 Likes

+1

In troubleshooting manual you have the instructions how to deal with a stuck install app.

went through line by line in manual and ride the lightning still flashes

I also have the same problem. Also tried uninstall the APP manually via cli then re-installing with the ./scripts/app command but still the same problem…

+Me… same issue… Looking for resolution in 0.4.9.

+1 here too, have just updated to from 4.6 to 4.8

  • Looking at it from the command line I have tried stopping and restarting the RTL container but seems to be just restarting over and over
  • I have uninstalled the app from the web user interface and then re-installed, however it is just flashing and stuck on starting when viewing from the webUI
  • I have looked at the logs of the container by running "docker container logs [RTLContainerID] and it has the following: env: can't execute 'bash': No such file or directory

Will prob need a fix in 4.9 if possible, otherwise RTL is not usable at this point in time.

@louneskmt is something general with updating RTL? First time I heard about this issue.

+1

Hey guys, this is a known issue on amd64 based Umbrels. It will be solved with the next release. For now, here is a hot fix to be executed from your Umbrel root dir:

sed -i "s/bash/sh/g;" app-data/ride-the-lightning/rtl/entrypoint.sh && scripts/app stop ride-the-lightning && scripts/app start ride-the-lightning

Link to the fix to be merged: https://github.com/getumbrel/umbrel/pull/1115

3 Likes

Thanks @louneskmt that absolutely did the trick :+1:

This also worked for me on Intel based system. Tried everything in troubleshooting guide but this was the fix.