Stuck at Starting Umbrel

Hi,

I have tried several FAQ’s regarding the stuck on Home Screen issue, but nothing seems to help. I did a debug and this is the info. Can someone help me?

Blockquote =====================

= Umbrel debug info =

=====================

Umbrel version


0.3.12

Umbrel OS version


v0.3.12

Raspberry Pi Model


Revision : d03114

Serial : 1000000007f52770

Model : Raspberry Pi 4 Model B Rev 1.4

Firmware


May 27 2021 14:02:15

Copyright © 2012 Broadcom

version 7d9a298cda813f747b51fe17e1e417e7bf5ca94d (clean) (release) (start)

Temperature


temp=66.7’C

Throttling


throttled=0x0

Memory usage


total used free shared buff/cache available

Mem: 7.8G 155M 7.3G 8.0M 359M 7.5G

Swap: 4.1G 0B 4.1G

total: 2.0%

system: 2%

tor: 0%

lnd: 0%

electrs: 0%

bitcoin: 0%

Memory monitor logs


tail: cannot open ‘/home/umbrel/umbrel/scripts/…/logs/memory-monitor.log’ for reading: No such file or directory

Filesystem information


Filesystem Size Used Avail Use% Mounted on

/dev/root 15G 2.9G 11G 21% /

/dev/sda1 916G 5.3G 865G 1% /home/umbrel/umbrel

Startup service logs


Jun 17 13:59:33 umbrel systemd[1]: umbrel-startup.service: Service RestartSec=10s expired, scheduling restart.

Jun 17 13:59:33 umbrel systemd[1]: umbrel-startup.service: Scheduled restart job, restart counter is at 93.

Jun 17 13:59:33 umbrel systemd[1]: Stopped Umbrel Startup Service.

Jun 17 13:59:33 umbrel systemd[1]: Starting Umbrel Startup Service…

Jun 17 13:59:33 umbrel umbrel startup[14211]: ======================================

Jun 17 13:59:33 umbrel umbrel startup[14211]: ============ CONFIGURING =============

Jun 17 13:59:33 umbrel umbrel startup[14211]: ========= UMBREL (mainnet) ===========

Jun 17 13:59:33 umbrel umbrel startup[14211]: ======================================

Jun 17 13:59:33 umbrel umbrel startup[14211]: Generating auth credentials

Jun 17 13:59:33 umbrel umbrel startup[14211]: Generating Tor password

Jun 17 13:59:34 umbrel umbrel startup[14211]: docker: Error response from daemon: error creating overlay mount to /var/lib/docker/overlay2/d3d5504c42ea09a45933f97832196182ba6f03e8a967d2de8ffd7a87cedf0058-init/merged: invalid argument.

Jun 17 13:59:34 umbrel umbrel startup[14211]: See ‘docker run --help’.

Jun 17 13:59:34 umbrel systemd[1]: umbrel-startup.service: Control process exited, code=exited, status=125/n/a

Jun 17 13:59:34 umbrel systemd[1]: umbrel-startup.service: Failed with result ‘exit-code’.

Jun 17 13:59:34 umbrel systemd[1]: Failed to start Umbrel Startup Service.

Jun 17 13:59:44 umbrel systemd[1]: umbrel-startup.service: Service RestartSec=10s expired, scheduling restart.

Jun 17 13:59:44 umbrel systemd[1]: umbrel-startup.service: Scheduled restart job, restart counter is at 94.

Jun 17 13:59:44 umbrel systemd[1]: Stopped Umbrel Startup Service.

Jun 17 13:59:44 umbrel systemd[1]: Starting Umbrel Startup Service…

Jun 17 13:59:44 umbrel umbrel startup[14334]: ======================================

Jun 17 13:59:44 umbrel umbrel startup[14334]: ============ CONFIGURING =============

Jun 17 13:59:44 umbrel umbrel startup[14334]: ========= UMBREL (mainnet) ===========

Jun 17 13:59:44 umbrel umbrel startup[14334]: ======================================

Jun 17 13:59:44 umbrel umbrel startup[14334]: Generating auth credentials

Jun 17 13:59:44 umbrel umbrel startup[14334]: Generating Tor password

Jun 17 13:59:44 umbrel umbrel startup[14334]: docker: Error response from daemon: error creating overlay mount to /var/lib/docker/overlay2/d3865dd3b8ae22fc6b96c03e56fea2c237ba11165b7951b0e1843b4be54f8458-init/merged: invalid argument.

Jun 17 13:59:44 umbrel umbrel startup[14334]: See ‘docker run --help’.

Jun 17 13:59:44 umbrel systemd[1]: umbrel-startup.service: Control process exited, code=exited, status=125/n/a

Jun 17 13:59:44 umbrel systemd[1]: umbrel-startup.service: Failed with result ‘exit-code’.

Jun 17 13:59:44 umbrel systemd[1]: Failed to start Umbrel Startup Service.

External storage service logs


– Logs begin at Thu 2021-06-17 13:17:01 UTC, end at Thu 2021-06-17 13:59:53 UTC. –

Jun 17 13:17:06 umbrel systemd[1]: Starting External Storage Mounter…

Jun 17 13:17:06 umbrel external storage mounter[487]: Running external storage mount script…

Jun 17 13:17:06 umbrel external storage mounter[487]: Found device “asmedia ASMT1051”

Jun 17 13:17:06 umbrel external storage mounter[487]: Blacklisting USB device IDs against UAS driver…

Jun 17 13:17:06 umbrel external storage mounter[487]: Rebinding USB drivers…

Jun 17 13:17:06 umbrel external storage mounter[487]: Checking USB devices are back…

Jun 17 13:17:06 umbrel external storage mounter[487]: Waiting for USB devices…

Jun 17 13:17:07 umbrel external storage mounter[487]: Waiting for USB devices…

Jun 17 13:17:08 umbrel external storage mounter[487]: Checking if the device is ext4…

Jun 17 13:17:08 umbrel external storage mounter[487]: Yes, it is ext4

Jun 17 13:17:14 umbrel external storage mounter[487]: Checking if device contains an Umbrel install…

Jun 17 13:17:14 umbrel external storage mounter[487]: Yes, it contains an Umbrel install

Jun 17 13:17:14 umbrel external storage mounter[487]: Bind mounting external storage over local Umbrel installation…

Jun 17 13:17:14 umbrel external storage mounter[487]: Bind mounting external storage over local Docker data dir…

Jun 17 13:17:14 umbrel external storage mounter[487]: Bind mounting external storage to /swap

Jun 17 13:17:14 umbrel external storage mounter[487]: Bind mounting SD card root at /sd-card…

Jun 17 13:17:14 umbrel external storage mounter[487]: Checking Umbrel root is now on external storage…

Jun 17 13:17:15 umbrel external storage mounter[487]: Checking /var/lib/docker is now on external storage…

Jun 17 13:17:15 umbrel external storage mounter[487]: Checking /swap is now on external storage…

Jun 17 13:17:15 umbrel external storage mounter[487]: Setting up swapfile

Jun 17 13:17:17 umbrel external storage mounter[487]: Setting up swapspace version 1, size = 4 GiB (4294963200 bytes)

Jun 17 13:17:17 umbrel external storage mounter[487]: no label, UUID=cb7d821c-cf89-43f7-a36a-a225147bd4f9

Jun 17 13:17:17 umbrel external storage mounter[487]: Checking SD Card root is bind mounted at /sd-root…

Jun 17 13:17:17 umbrel external storage mounter[487]: Starting external drive mount monitor…

Jun 17 13:17:17 umbrel external storage mounter[487]: Mount script completed successfully!

Jun 17 13:17:17 umbrel systemd[1]: Started External Storage Mounter.

External storage SD card update service logs


– Logs begin at Thu 2021-06-17 13:17:01 UTC, end at Thu 2021-06-17 13:59:53 UTC. –

Jun 17 13:17:24 umbrel systemd[1]: Starting External Storage SDcard Updater…

Jun 17 13:17:24 umbrel external storage updater[841]: Checking if SD card Umbrel is newer than external storage…

Jun 17 13:17:24 umbrel external storage updater[841]: No, SD version is not newer, exiting.

Jun 17 13:17:24 umbrel systemd[1]: Started External Storage SDcard Updater.

Karen logs


tail: cannot open ‘logs/karen.log’ for reading: No such file or directory

Docker containers


NAMES STATUS

Bitcoin Core logs


ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

LND logs


ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

Tor logs


ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

================

==== Result ====

================

This script could not automatically detect an issue with your Umbrel.

Please share the following links and paste it in the Umbrel Telegram group (https://t.me/getumbrel) so we can help you with your problem.

tail: cannot open ‘/home/umbrel/umbrel/scripts/…/logs/memory-monitor.log’ for reading: No such file or directory

tail: cannot open ‘logs/karen.log’ for reading: No such file or directory

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:

networks.default.ipam.config.subnet is invalid: should use the CIDR format

services.tor.ports contains an invalid type, it should be a number, or an object

services.bitcoin.ports contains an invalid type, it should be a number, or an object

services.electrs.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.lnd.ports contains an invalid type, it should be a number, or an object

services.nginx.ports contains an invalid type, it should be a number, or an object

services.lnd.ports value [‘9735:9735’, ‘:’, ‘:’] has non-unique elements

https://umbrel-paste.vercel.app/acc15c45121bc7664127a2a747a9a6c6

umbrel@umbrel:~ $

1 Like

Someone on Telegram helped me fix the problem. He told me to use this command in Terminal/SSH:

sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service

Running my node now! :slight_smile:

3 Likes

I tried this but got this message

Total reclaimed space: 1.108GB
A dependency job for umbrel-startup.service failed. See ‘journalctl -xe’ for details.

None of this worked for me. Instead, I removed the microSD from my Raspberry Pi 4b and re-flashed Umbrel OS image again following the normal steps at getumbrel.com.

It took like 10 minutes and as everything was in my SSD, my node was already synced and my wallet working fine.

Trying @farl command, I am getting the same error as @dlevens . I tried re-flashing like frank suggested with no luck either.

Anyone have an other ideas?

Here is some debug info:

Blockquote
– The job identifier is 3095.
Jul 08 05:16:25 umbrel umbrel startup[11959]: ======================================
Jul 08 05:16:25 umbrel umbrel startup[11959]: ============= STARTING ===============
Jul 08 05:16:25 umbrel umbrel startup[11959]: ============== UMBREL ================
Jul 08 05:16:25 umbrel umbrel startup[11959]: ======================================
Jul 08 05:16:25 umbrel umbrel startup[11959]: Setting environment variables…
Jul 08 05:16:25 umbrel umbrel startup[11959]: Starting karen…
Jul 08 05:16:25 umbrel umbrel startup[11959]: Starting memory monitor…
Jul 08 05:16:25 umbrel umbrel startup[11959]: Starting backup monitor…
Jul 08 05:16:25 umbrel umbrel startup[11959]: Starting decoy backup trigger…
Jul 08 05:16:25 umbrel umbrel startup[11959]: Starting Docker services…
Jul 08 05:16:28 umbrel umbrel startup[11959]: Starting electrs …
Jul 08 05:16:28 umbrel umbrel startup[11959]: Starting tor …
Jul 08 05:16:28 umbrel umbrel startup[11959]: dashboard is up-to-date
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 1(veth440c835) entered blocking state
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 1(veth440c835) entered disabled state
Jul 08 05:16:28 umbrel kernel: device veth440c835 entered promiscuous mode
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered blocking state
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered disabled state
Jul 08 05:16:28 umbrel kernel: device vethfc07e97 entered promiscuous mode
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered blocking state
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered forwarding state
Jul 08 05:16:28 umbrel dockerd[641]: time=“2021-07-08T05:16:28.573747839Z” level=warning msg="Failed to allocate and map port 50001-50001: Bind
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 1(veth440c835) entered disabled state
Jul 08 05:16:28 umbrel kernel: device veth440c835 left promiscuous mode
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 1(veth440c835) entered disabled state
Jul 08 05:16:28 umbrel dockerd[641]: time=“2021-07-08T05:16:28.663973696Z” level=warning msg="Failed to allocate and map port 9050-9050: Bind f
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered disabled state
Jul 08 05:16:28 umbrel kernel: device vethfc07e97 left promiscuous mode
Jul 08 05:16:28 umbrel kernel: br-b3c16ab39065: port 2(vethfc07e97) entered disabled state

`

Tried this but got ‘systemctl: command not found’.

Also tried reflashing and now stuck on Starting Umbrel again. On the Telegram I was told that noobs need to be patient - it’s 4 days later!

Any ideas anyone? Thanks.

1 Like

@mayank and @lukechilds this seems to be disconnected form the drive.
What do you suggest?

DarthCoin suggested in telegram it was a hardware issue. I ended up replacing the power cord and the cord to the SSD. One of those seemed to fixed the issue. Thanks again @DarthCoin

1 Like

I first used a HDD and changed it to SDD and that worked for me. The hardware specs are important.

1 Like

I also got this. Did you find a solution?

I had this issue and discovered that I needed to initialize my SSD then format. I did this on a Windows machine and it solved the problem. You’ll need to treat it as a new drive in Disk Management by initializing and creating an MBR partition. Then format the drive and reconnect to RPi

Are you using the SSD suggested by Umbrel? (Crucial MX500 1TB)