Trying to connect Sparrow to Umbrel

So I’m trying to connect my Sparrow wallet to my Umbrel. When I follow the “connect wallet” steps in Umbrel and then try to Test Connection, I get:

"Could not connect:

Error reply: Unable to set option: Failed to bind one of the listener ports.
Is a Tor proxy already running on port 9050?

Assuming Tor proxy is running on port 9050 and trying again…"

Followed immediately by:
“Could not connect:
SOCKS: Host unreachable. Check if the proxy server is running.”

Any help would be appreciated. Thanks.

  1. If you run Sparrow on a PC in the same LAN as your umbrel node, you can use umbrel.local:50001 as electrum server to connect your Sparrow. Put your node IP as umbrel.local in your PC hosts file first.
  2. If you connect from outside LAN, then you need to run Tor service (not browser) on that machine, in order to be able to connect to your electrum server, through Tor.

Follow the instructions from “connect wallet - electrum”

1 Like

This worked! Thank you very very much.

1 Like

I have the same issue, but I just started, so I only have Umbrel 5.0
The connect wallet dropdown is no longer an option Umbrel 5.0- is there a solution to check if the tor system is up and running?

I have the same issue. I have umbrel 5.0 and it’s different. I have the tor browser installed on local computer but I don’t know if that’s exactly what they mean. When they say enter your electrum remote URL, are they talking about the Bitcoin core RPC address (RPC tor or P2P)?

@legalbabble26 & @allaboutsats having the same issue after updating to 5.0.

Having same issue, were you able to find a solution? @kylecullen @legalbabble26 & @allaboutsats

No, I figured it out. Huge rookie mistake. I did not know the electrum server information for sparrow was in the Electrs app in Umbrel. It didn’t click. Thanks

Hi DarthCoin, if you can help I would be sooooooo grateful!

I have attempted to follow these instructions to connect PC and node on same LAN and I get the below response… I have tried everything to get Tor running as a service but for some reason no matter whos online advise I follow I can’t get the service to start so I’m back to trying to connect via umbrel.local

Could not connect:

Connection refused: connect

Oh so you need to install and synch the electrs app first?

Yes. If you are trying to connect sparrow to your node using the electrum server tab, go to your umbrel dashboard, then the App Store. Install electrs. Then go into electrs, select the tor tab then use that onion address with port 50001.

Electrs on your node is what they call “Your personal electrum server URL”. That’s what confused the crap out of me. I was like, “ what server URL?” Lol

Did that work out for you?

Awesome cheers for that… just waiting for electrs to sync and then will see how I go!

1 Like