Umbrel 5.0 Update -- Where is bitcoin.conf?

I had a whole routine down when updating – ssh to the node, update my config.

Now, I see two containers with “bitcoin” in their name and have no idea where the bitcoin.conf file lives.

Is it in “bitcoin_server_1” or “bitcoin_bitcoind_1”? I tried to do some commands like – docker exec < container name > ls -l just to find out what the directory structure is like, but I don’t see it.

Where did it go? Do I have to make a new one? What is going on?

Update – tried to find the file using “find . -name bitcoin.conf” both in the root and inside the container. No dice. Not sure where to create a new one or where it is… 20+ views and no answer? I feel sorry for the newbies that need to config their Bitcoin node…

I’m THIS close to wiping this entire SD Card and either rolling back, or just installing whatever flavor of Linux RasPi will support and just doing it all myself. This is ridiculous.

For those looking for prior releases to potentially roll back – https://github.com/getumbrel/umbrel-os/releases

Older version instructions:

2 Likes

Hi TallTim, you can create it into: /umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf

Thanks, but that is utterly weird that there’s no bitcoin.conf in there – it always existed in prior versions. I’ll just create one.

By creating a bitcoin.conf file it will override all the options passed to bitcoind to start. So, if I want to just add anything to the configuration, I need to get all the options from the daemon to put in it too, to respect the Umbrel defaults.

I was wonder if there’s a way to just pass a one more simple option to the bitcoind.

2 Likes

HI, have you been able to get the exsting configs on the default bitcoin.conf file so your custom created config wouldnt totally override the default?

I am interested in this solution as well.

1 Like

Can you find it? I am facing the same problem as you. I’m not sure what you guys are saying about the bitcoin.conf file is to recreate it in the directory?

1 Like

Did you solve this? I would live to increase my bitcoin mempool size but don’t want to just create a new bitcoin.conf with just one line maxmempool=1000 since I don’t have or know of the other config options.

1 Like

I have this exact same question my self. I want to try different mempool sizes and wonder what is best practice for changing only this setting and nothing else? And prefereably this setting would persist across updates… Any one have a answer for us?

After version 0.5 the bitcoin.conf file actually doesn’t exist by default, the default options are now set using command line parameters. However, you can still create and edit bitcoin.conf and add custom lines to it. The new path is shown here, and this command allows you to add new lines:
sudo nano ~/umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf

After you’ve added your new lines you can CTRL+X to exit, then Y to save, and then enter to skip renaming file to proceed.

Then you’ll need to restart Bitcoin for the change to take effect:
~/umbrel/scripts/app restart bitcoin

1 Like

Thank you!

does this disrupt any other settings? I have enabled a few features like bloom filters and compact block filters but wanted to see other’s experience with having a custom bitcoin.conf file. However after creating the bitcoin conf file with varaibls such below bitcoin stopped connecting to peers and was not downloading block data.

# Enable all compact filters
blockfilterindex=1
# Support filtering of blocks and transactions with bloom filters
peerbloomfilters=1
# Serve compact block filters to peers per BIP 157.
peerblockfilters=1
# Maintain coinstats index used by the gettxoutsetinfo RPC 
coinstatsindex=1