Umbrel BTC and Lightning Wallets status stuck at "Synchronizing"

I restored with my node, originally on a QEMU Ubuntu installation within macOS on an Intel iMac, to a flashed SD card on a Raspberry Pi 4. Following installation and restoring and letting the whole block sync, I upgraded my Umbrel node to version 0.3.10.

The node is syncing but my Lightning Wallet and Bitcoin Umbrel wallets are perpetually “Synchronizing.”

Has anyone experienced this? How do I troubleshoot this?

Hi

I did have a similar problem. I restored my node and got stuck on 'loading bitcoin core".

I followed these instructions and it helped me.

Thanks!

Follow-up question before I try: Is “re-indexing” the block chain the same thing as validating it for the first time? Took me several days when the Umbrel first fired up.

Yes, unfortunately it’ll re-validate the blockchain again for another serveral days (on a pi4 that is).

:pray:t3:

I have the same issue with Umbrel 0.4.0, I rebooted and still synchronizing.

2 Likes

Same here. I started with a 128 GB microSD card just because that is what I had at the time. Figured maybe too much capacity was an issue so I got a 32 GB microSD and flashed that with the latest OS, but the same thing is happening now too.

The wallets never even show 0 sats for me like your screenshot… but instead, a pulsing grey bar (same with my overall Balance display on the Home page).

This happened on initial setup even with the blockchain 100% synched and has been validating new blocks for multiple days. I followed all the instructions but am not technical, don’t even know how to SSH - but is that really necessary?

There’s a suspiciously low amount of support content around this issue, almost as if we simply did something wrong upon installation. Doesn’t seem like there’s much room for error. I’m really confused. Can’t find any way to get help. Please help!


3 Likes

Same here. I followed the installation step as-is and node was synced up to 5% then all the sudden I can’t see anything… It just says synchronizing, I tried reflashed the SD card and still nothing.

Can anyone help with this issue ?

2 Likes

Exciting update! Installed Ride the Lightning app on the Umbrel and now Lightning and Bitcoin wallets alike show as Active for the very first time

Hi there!
Any news on this topic? Installing RTL didn‘t help in my case.
After recovering my node with the seedphrase and the Bitcoin Core now fully synchronized, my bitcoin- and lightning wallet keep stuck in the synchronizing status. I can see my funds using Zap desktop but umbrel stays empty with a flashing grey beam…

Guys, if you just post some bunch of screenshots, nobody can help you with more info.
It could be many reasons why this can happen:

  • old version of Umbrel OS
  • Electrs service is still indexing/ctaching up blocks
  • bad restart
  • your ext drive is not well connected
  • you have some bad line in lnd.conf so LND it doesn’t start
  • you have a wallet locked
  • some other component that doesn’t start

So please read the Troubleshooting manual and use the command to generate the debug log with upload option so you can share it.
Read first that log, entirely, line by line and understand what is going on.
If you really don’t understand (is pretty intuitive the log), you can share here the log link (not pasting the whole log as text).

3 Likes

Here is my debug log: https://umbrel-paste.vercel.app/ceaa04db842bbcd7e2663ceea0cdd6d8
I read it carefully and I think the Problem is in the LND logs, where it says: “wallet not created, create one to enable full RPC access”
And thats where I´m stuck. Since I recovered with my seed, I thought it would automatically recreate the wallet…
Thanks for your help!

Edit:
-Newest Umbrel OS version
-up & running for several hours
-restarted several times
-triple checked the ext. SSD
-how do I check a bad line in lnd.conf
-how do I unlock my wallet if its locked?

Just managed to fix it by resetting my Umbrel user data via ssh.

2 Likes

Nice. I really like when users can debug, read documentation ad fix themselves. This will empower them for further use of their nodes.

1 Like

hi.
how did you do it. I think I have the same issue, which command did you use.

!!
Beware- you only keep the synchronized bitcoin core, everything else is wiped off. So be sure to have your seed and channel backup !!

sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm ~/umbrel/db/user.json && sudo rm ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

2 Likes

I had a similar experience after upgrading to 0.4.4 except the wallets were synchronized but would fail when trying to access the ln wallet. The on chain wallet was functional. So I transferred out all my on chain balance except for some dust. The ln balance was stuck.

Here’s how I recovered
-burn upgraded 0.44 SD
-load new instance onto Umbrel
-import seed phrases
-Removed all apps Thunderbird, RTL, BTC pay.
-Re-installed all apps

The errors recovered and both wallets were accessible with no loss in funds.

Hi did you resolve your problem, as i have the same issue. I’m a newbie and have no idea what to do. Too much information on this community. Any advice?

I think i found a solution for that.

  • wait for the 100% in your bitcoin core (compare the last mined block number with mempool.space)
  • Connect via SSH to ur umbrel (via putty for example)
  • go in the umbrel folder (cd umbrel)
  • stop everything -> “sudo ./scripts/stop”
  • patience
  • start everything again -> “sudo ./scripts/start”
  • patience … patience … after maybe 15 minutes login to ur umbrel website and everything is back again…

i made this a few times and it works everytime for me

cheers