Umbrel not recognizing SSD

My system kept crashing. I kept restarting. It was not fun. I replaced the SSD case with this cable:
SATA to USB Cable, Benfei USB 3.0 to SATA III Hard Driver Adapter Compatible for 2.5 inch HDD and SSD. So now the Pi connects directly to drive. No cash on hard drive.
And it’s working like a dream! Can’t thank you guys enough. Great job!! That cable is $10 on Amazon. Came next day and bingo!

I have the same Sandisk SSD and it worked. i would try not putting anything into your USB plug other than the SSD USB. and use the normal power plug

I have a 3.0 to sata cable on order from crucial. I hope that will do the trick. I will follow up

This finally worked. I have no idea what was different or the cause of the issues. It hung on starting up overnight and when I woke it was synching.

I wish I had a better solution to share…

Also, formatting the SSD to the correct format (Ext4) is SUPER IMPORTANT but a step which I feel is missing from the installation instructions. I followed the User Guide step by step but completely missed formatting, thinking that it would be included in the boot sequence.

To help total noobs I think it would be useful to mention the formatting required for the SSD/HDD before booting Umbrel.

I changed an enclosure to a cable, reformatted my SSD and rebooted Umbrel and we’re syncing (55% in 4 days)…

Looking now at the quickest and least power-sapping SDDs. In hindsight, I should have maybe gone for an NVMI M2 style SSD with an extension board - wish I had know this was an option before buying my Crucial MX500.

Yes, correct format of SSD is ext4.
But that is done also when you install first time Umbrel.
So if the drive is brand new (no partitions) it will be formatted in ext4 in the process.
Formatting it in ext4 from the beggining it doesn’t hurt, but users should keep in mind: do not format it in NTFS or using Windows systems. That will make unusable the disk and you will need to re-format it in ext4.
In the troubleshooting manual there’s a procedure mentioned (for when you want to copy the blockchain data from another source) about how to use ext4 disks on Windows.

y know? I still appreciate what you shared a lot. I have the same problem here. The system tells me that the SSD is okay, but the website still says: NO (Please connect an external drive (at least 1TB) to a USB 3.0 port (blue color) on your Raspberry Pi and restart your Umbrel.)

I hope tomorrow when I wake up I will has the same result like you ^^

In the beginning, I had lots of those problems with external drive, files corruption, etc, and found problems both in USB cable and USB to SATA adaptor.
If you decide to do a new clean install, before it, ask and i can show you simple tests to verify those parts.

1 Like

Same issue here with a Brand NEW BitcoinMachine :thinking: the green light on the (2TB) SSD turns ON (Green - Not Blue) but the Ui always shows the same message:

I’ve already:

  • open the box and check if the hardwares are well connected
  • rebooted the TBM few times (no change)
  • connect the SSD with different USB cable (no change + replaced the original one)

@LoboGuara please do share those tools for testing, it will be really useful :pray:

Sorry for the issue!

For @n080dy and The Bitcoin Machines users, can you please confirm if everything is connected correctly as per the instructions on this article here?

@mayank yes, confirming everything was connected, but just green light, no blue ligh… now the BTM is unmounted and I’m worries the HD or the USB connector are gone and need replacement.

I already connected the HD to a macOS and the drive is not recognised from the Utility Disk nor from terminal when running a df -hcommand

If there’s a way I can fix/reset the HD or check somehow if the USSB connector still alive will be great… Or alternatively what will be next step?

Thanks in advance

HD is not suitable to this project. Recommended use SSD.
You need a sata-to-usb3 adapter (external disc case) to test the SSD.
With it, writing files and testing write speeds to the SSD gives hints what is the bad part.

@LoboGuara sorry my mistake, for HD I actually mean the SSD that came by default with theBitcoinMachine. Today discovered that the SSD died already, so I had to buy another one.

Now, replaced the SSD and the blue light is on, but the same message still appearing. Restarted twice, same result.

What else it can be?

Thanks

Do you have a spare sata adapter (case) to test directly the Rasp Pi to the SSD, bypass the machine internal sata chip?
Or verify if you can test the internal sata chip, plugging the internal sata adapter to a PC with a usb3 cable? (to this tests cut off any power source to the internal board, unplug the usb3 connector to the Rasp Pi)

@LoboGuara yes that what I did, I’ve unmounted the SSD from the case and from the DOiDO internal board and connected to via USB to my computer:

  • the old one is death on my PC, (green light when attached to TBM) no signs of detection at all
  • the new one is detected on my PC, (blue light when attached to TBM) and PC ask me to format the drive

I understand that the drive need to be plugged in the DoiDO board with factory defaults and umbrella will take care of everything. is that correct or shall I format the new SSD to ext4?

Before you mount ssd to machine, test the machine board with SSD in. Using a usb2 port of a PC or laptop, format the SSD, ntfs or fat32. Then write a large file to it ( 1GB or greater). Change cable to a usb3 port. Next, do a copy of the large file in the SSD to itself. Observe the copying speed. If everything is good, speed should be no less than 100MB/s and stable during copy, with no dips.
If speed dips or even stops, you may have a bad usb cable. If copy speed is stable but lower than 100MB/s, likelly the sata chip onboard is issued.
Obs. be sure test using usb3 cable and usb3 PC port, if using usb2 parts you will get lower copy speed (30MB/s or less) and issues may not appear.

1 Like

Umbrel will format SSD to ext4, not to care about this.

1 Like

Ok apparently macOS does not offer ntfs or fat32, shall i go with the MS-DOS (FAT) option?

@n080dy Use the ExFAT option, since Umbrel will format it to ext4 (extFS 4) automatically at first setup. If you used the MS-DOS (FAT) then it will only format up to 64GB out of whatever you have on the SSD – which you don’t want.

1 Like

@DHD @LoboGuara just tried as follows below:

  • formatted to ntfs using ntfsmac15_trial
  • did not work, so I still seeing the same error on umbrel.local and blue light on the SSD
  • formatted to ext4 using extFS_trial
  • did not work either, so I still seeing the same error on umbrel.local and blue light on the SSD

The weird thing is the blue light turning on. I understand that signal is sent from umbrel to confirm that the SSD is recognised, right? or is just hardware confirmation?

Not sure what I’m doing wrong here… everything is connected! anything else can I troubleshoot via ssh?