Lightning channel stuck in "Waiting Close"

I initiated a channel close on Umbrel 2 weeks ago but it remains stuck on “closing”." If I select “view info” on the channel in RTL (Ride The Lightning), I can see it under “Waiting Close.” I have tried restarting my node several times.

If anyone can provide the command to force close the channel via command prompt that would help. I have managed to connect via C:\WINDOWS\system32>ssh umbrel@umbrel.local

Managed to figure it out. Executed the command via command prompt on desktop PC to force close:

Connect to Umbrel:

C:\WINDOWS\system32>ssh umbrel@umbrel.local

Execute command:

umbrel@umbrel:~ $ ~/umbrel/bin/lncli closechannel --force //(channel point with a space instead of “:” )

Transaction was re-broadcast successfully. “blocks_til_maturity” of 143 so presumably have to wait for these to clear before funds are returned.

2 Likes

@bitcarnicoin I have the same issue, but I’m confused what you meant by "channel point with a space instead of a : "

When I tried the command to force the channel to
“037cc5f9f1da20ac0d60e83989729a204a33cc2d8e80438969fadf35c1c5f1233b@165.227.103.83:9735”

I did ~/umbrel/bin/lncli closechannel --force 037cc5f9f1da20ac0d60e83989729a204a33cc2d8e80438969fadf35c1c5f1233b@165.227.103.83 9735

But I got the error [closechannel] unable to get funding txid: max hash string length is 64 bytes

So I tried the TXID I used for opening the channel

~/umbrel/bin/lncli closechannel --force <TXID>

The error from the logs was [/lnrpc.Lightning/CloseChannel]: channel not found

I’m not sure what I’m doing wrong here…

Just kidding! The channel point is found when you enter ~/umbrel/bin/lncli pendingchannels

And look inside the waiting_close_channels array for channel_point… from there it’ll be a string like

851ddc0900b775ff4afbd12ed4c8c003456eaea862ba96664344b06a04eec7c5:1

And to close the channel it’s like you said

~/umbrel/bin/lncli closechannel --force 851ddc0900b775ff4afbd12ed4c8c003456eaea862ba96664344b06a04eec7c5 1

Hope this helps someone in the future!

3 Likes

One more thing, after the closechannel command works, you can see when your funds will be released in the maturity_height value inside the pending_force_closing_channels array.

~/umbrel/bin/lncli pendingchannels

"pending_force_closing_channels": [ ...."maturity_height": 694303,

1 Like

@Mikey @bitcarnicoin - Thanks guys, this helped me as well!