Samourai wallet showing 0 balance since 0.4.1

My wallet is showing zero balance with no outgoing transactions to justify this. The 3 deposits i’ve made into it are showing with no outgoing transactions, yet the balance is completely empty. The wallet is connected to samourai server on my node.

Obviously this is very concerning. I spoke with samourai and they said it is likely an issue with the 0.4.1 upgrade and that my funds could be restored by the seed phrase to another wallet. Do you have any advice for this?

Thanks.

2 Likes

I looked in the Umbrel logs and there are some error messages saying aborted connection to Samourai server if that helps to explain

My Samourai wallet is the same. Have Umbrel been able to help users with this issue yet? Seems with every update I end up with issues trying to run Ronin Dojo via Umbrel… Appreciate any help/advice on this. Cheers :slight_smile:

I sent $1000 from my Exodus wallet to a Samourai + Umbrel node wallet without checking if it worked on smaller amounts because I’m a fucking idiot.

The funds left Exodus, but they did not appear in Samourai. Naturally, I was a bit nervous. Deleting and restoring the Samurai wallet didn’t work. I contacted Samourai support, who said, “It appears your wallet may have been somewhat out of sync with our nodes. I’ve just resynced our nodes for that address, and you should now be able to get your balance and transaction history displaying properly in Samourai.” I was able to send my funds from Samourai back to Exodus after that.

So Samourai doesn’t seem to be working with Umbrel for whatever reason.

I have a similar issue.

I downloaded the Samourai wallet on my phone and followed instructions to connect Dojo by using my Umbrel node which runs on Rasberry pi.

I made a small deposit into the wallet as a test but it didn’t show up. It still says 0 balance and 0 transactions.

However, if I check the public address on Bitcoin Explorer, it says the wallet has the right balance with a single transaction.

I’ve tried reaching to the Samourai support team but they couldn’t help. They said “Please follow up with the Umbrel support team for assistance on that as unfortunately we are unable to provide in depth support for third party Dojo implementations such as that of Umbrel”

What’s my best bet to get my bitcoin back? recover the funds with a different wallet provider? wait for a resolution for this issue?

2 Likes

Use the XPUBS Tool in Dojo and rescan your XPUB (can get it in Settings --> Wallet in the Samurai App).

That worked for me, but now I’m struggling with Whirlpool transactions missing since I had to reinstall Dojo because it stopped syncing (Major Issue #2).

Edit: Be sure to ‘Retype’ the scan as BIP84 before rescanning.

1 Like

Thanks,

I had tried that as suggested by the Samourai support team but it didn’t help.

I tried uninstalling the wallet app and reinstalling it, now I can’t even connect Dojo.

Maybe lack of synchronization between wallet and node is why I’m having trouble?

Any more suggestions?

Did you recover the funds via seed phrase or find anyway to get the funds out of whirlpool? Mine are stuck also

Did you figure out how to get it to resync? Mine is also off sync for trackers and DB.

I have the exact same issue as the thread starter.
Please UMBREL FIX THIS ASAP.

I recovered the wallet and connected to the wallet provider’s node. I had to additionally go to Settings/Troubleshoot/Send backup to tech support to get it to sync and display my bitcoin.