Specter Desktop and Umbrel

So I have been trying to set up my Specter Desktop (on my laptop) to connect to my full node (rasp pi, Umbrel) and I am having a terrible time.

First off, i have read that it is better to download Specter Desktop than to use the Umbrel Specter app due to wallet connection issues. Is this still true? I mean whats the point of the specter umbrel app if you cant use it with your hardware wallets?

Secondly, i have now downloaded Specter Desktop, connected my Full Umbrel Node and now I am trying to get specter desktop to recognize my HWW (i have ledger, bitbox02, coldcard, and Cobo. But im trying with my ledger first). When i run through the steps that and i try to test the connection, it still doesnt work. At this point im uber frustrated. Im not a programer but usually can to do basic computer stuff, why is this SOOOO HARD. Please help! And thank you in advance!

You have to use Specter HWIBridge, it’s fairly easy. Here are the instructions on their GitHub.

As @Aydo has suggested you need to use a version of Specter to run on your computer and then use the version on your Umbrel as a remote of sorts. This is true for any wallet that uses a usb connection. Coldcard will work with just the Specter Umbrel app.

Ok so I’m trying to set up my HWi bridge and I keep getting stuck in the very beginning. When I go to preferences and select run specter remotely. Where do I find my specter remote url? Thank you for your help!

It’s been a while since I did it. I believe I put localhost or loopback address for the remote url. You might get an answer faster if you ask in Specter’s community forums or Github repo.

Just to let you know that it worked for me, I ended up installing specter desktop on windows 10.
In preferences on the desktop wallet recently installed you will need to click on “Yes I run specter remotely” because as you mentioned you have it installed on umbrel app already. Then on preferences as well you need to paste your umbrel local adress which should look like this: “http://umbrel.local:25441” .
You will also need to whitelist the local adresses as well I think. You will need to be patient and insist a bit. lol

1 Like