SSD keeps disconnecting

I’m in the same boat; did you get the thing a they are suggesting?

Did it work?

I got the direct cable, reflashed etc. and now i get this

ok so 3rd usb port out of 4 and it worked. happy days!!

Got the same everytime i try to launch…

So it work just by changing the usb port?

Sorry for late reply, yes it did. How did you go?

tried the two USB 3.0 port nothing change…
Keep trying, to restart, shutdown,unplugged,move some things… nothing works…
Dont wanna flash my SD again as i was just sync…

I noticed the recommended SSD enclosure is different now compared to the previous one that was recommended on Umbrel’s site. I’m curious if this is a deliberate decision by Umbrel since that older enclosure was giving us such grief? Or if they’re simply recommending a newer model and it still causes this nonsense?

Previously recommended SSD enclosure that I purchased and had all the same kind of issues as you guys: https://www.amazon.com/dp/B01M08LCXW/ref=cm_sw_em_r_mt_dp_4VD3JK9BD7CDQ8F7DGDB?_encoding=UTF8&psc=1

Currently recommended SSD enclosure: https://www.amazon.com/dp/B01N48791I/ref=cm_sw_em_r_mt_dp_CP2ZXYX0TVP1GR71JV0R

I had much of those external drive connection, container issues, etc, but found it was not hardware problem.
What got me rid of it was to take the SSD to Windows, open disk manager and just exclude the whole partition (something about 950 GB). Then take SSD to Pi and do a new instalation.
So, problem was with incompatible formatation of SSD.
I have ordinary cheap parts, but everything is fine since then.